Greasemonkey 4: Firefox 57 -yhteensopivuus

Suositun käyttäjärekisteritiedoston Greasemonkey for Firefoxin kehittäjät ovat ilmoittaneet Greasemonkey 4: n, uuden selainlaajennuksen version.

Greasemonkey 4 on yhteensopiva Firefox 57: n kanssa, koska se julkaistaan ​​WebExtensionina. Mozilla aikoo pudota Firefoxin vanhan lisäjärjestelmän tuki kun Firefox 57 Stable julkaistaan.

Vaikka joitakin vaihtoehtoja jatkaa vanhojen lisäosien käyttöä joissain Firefox-versioissa ainakin toistaiseksi suurin osa niistä on luonteeltaan väliaikaisia.

Tämä tarkoittaa puolestaan ​​sitä, että lisäosakehittäjien on portattava lisäosat, jotta ne pysyvät yhteensopivina Firefox 57: n ja selaimen uudempien versioiden kanssa. Kaikkia lisäosia ei voida toisaalta siirtää, koska WebExtensions-järjestelmä ei toista Firefoxin vanhan lisäjärjestelmän toimintoja kokonaan.

Päivittää : Greasemonkey 4 on nyt saatavilla WebExtensionina Mozilla AMO: lla.

Greasemonkey on Firefoxin korkean profiilin laajennus. Sillä on yli 880 000 käyttäjää kirjoittamishetkellä. Mozilla AMO: n nykyinen Greasemonkey-versio on vanha lisäosa. Tämä versio ei enää toimi Firefox 57 Stable- tai Beta-versioissa, jos Mozilla ei muuta aikataulua.

greasemonkey 4

Greasemonkeyn kehittäjät ilmoitti virallisella projektisivustolla, jonka Greasemonkey 4 on töissä. Tämä uusi selainlisäosan versio on täysin yhteensopiva Firefox 57: n kanssa. Se on hyvä uutinen lisäosan käyttäjille, vaikka vaihtoehtoja, kuten Violentmonkey tai Tampermonkey ovat myös saatavana ja yhteensopivia Firefox 57: n kanssa.

Haittapuoli tälle on se, että muutto rikkoo yhteensopivuuden joidenkin käyttäjän kirjoitusten kanssa. Mozilla luomilla uusilla sovellusliittymillä ei pakotettu tätä muutosta kehittäjille, mutta se on ollut tarkoituksellinen päätös.

Seurauksena on, että Greasemonkey-version versio 4 on melkein täydellinen uudelleen kirjoittaminen. Sen käyttöliittymä ja ominaisuusjoukot on rakennettu uudelleen, jotta ne toimisivat parhaiten tulevien Firefox-versioiden kanssa. Erilaisia ​​kompromisseja on tehty. Olemme päättäneet tehdä harvinaisen taaksepäin yhteensopimattoman muutoksen.

Päätös tuettiin vain käyttäjien kirjoituksia, jotka on suunniteltu toimimaan asynkronisesti suorituskykysyistä. Tämä rikkoo yhteensopivuuden vanhempien komentosarjojen kanssa.

Greasemonkey 4 on saatavana alfa-versio tällä hetkellä . Yhteensopivuus on rajoitettu Firefox 56: een ja sitä aikaisempaan versioon, eikä Firefoxin uusin versio, Firefox 58.

Greasemonkey-käyttäjien on selviydyttävä toisesta muutoksesta: lisäosan versiossa 4 ei enää ole tekstieditoria, vaan se lukee sen sijaan sulautettuun editoriin. Tämä on uuden WebExtensions-järjestelmän rajoitus, koska laajennukset eivät enää pääse tiedostojärjestelmään.

Loppu sanat

Seuraava Greasemonkey-versio on yhteensopiva Firefox 57: n kanssa. Se on hyvä asia, vaikka se tarkoittaa, että jotkut skriptit eivät enää toimi siinä versiossa, elleivät niiden tekijät päivitä niitä.

Nyt sinä: Kuinka otat ilmoituksen? Käytätkö käyttäjän kirjoituksia?